hdoj 1009 FatMouse' Trade解题报告

链接:hdoj1009

FatMouse’ Trade

**Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 60482 Accepted Submission(s): 20335

**

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

 

Sample Output
13.333 31.500
我的天,一道很简单的贪心题,然而一开始就TE,我还以为循环遍历太多,需要剪枝之类的优化,后来发现了两个地方的错误。。。好丢人Orz,,,
while (scanf("%d %d",&m,&n)&&m!=-1)
一开始是这里,忘记判断m=-1时结束输入,这应该是造成TE的原因;

第二个地方,是关于比例j[i]/f[i]的处理,f[i]可能为0,将其mods设为double类型最大值即可。

scanf("%lf %lf",&a[i].a,&a[i].b);
if(a[i].b==0)
{
    a[i].mods=DBL_MAX;
}
else
{
    a[i].mods=a[i].a/a[i].b;
}

嗯,就这么多,下面是完整代码:

#include<iostream>
#include<stdio.h
#include<math.h>
#include<algorithm
#define DBL_MAX 1.7976931348623158e+308
using namespace std;
struct food
{
    double a,b,mods;
};
food a[1001];
bool compare(food a,food b)
{
    return a.mods<b.mods;
}
int main()
{
    int m,n;
    double ans;
    while (scanf("%d %d",&m,&n)&&m!=-1)
    {
        for (int i = 0; i < n; i += 1)
        {
                scanf("%lf %lf",&a[i].a,&a[i].b);
                if(a[i].b==0)
                {
                    a[i].mods=DBL_MAX;
                }
                else
                {
                    a[i].mods=a[i].a/a[i].b;
                }
        }
        sort(a,a+n,compare);
        ans=0.0;
        while (n)
        {
            n--;
            if (m>=a[n].b)
            {
                m-=a[n].b;
                ans+=a[n].a;
            }
            else
            {
                ans+=m*a[n].mods;
                m=0;
            }
            if(a[n].b!=0&&m==0)break;
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}

 

细节啊细节,c++中对数的处理和java中还是有些区别的,需要谨慎。


文章作者: crazyX
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 crazyX !
评论
  目录